Support

Where to find answers about Rainbow

The first place to look for answers when using Rainbow is the built-in help for each function (click the Help button) or the User Guide. You will find the User Guide on the Rainbow menu or tab, or you can download a copy here:

If the User Guide does not answer your question, and it is not covered in the “frequently asked questions” below, please send an email to support@themodelanswer.com, giving as much detail as possible about what has happened. If you are using Rainbow version 7.0 or later, please also copy and paste into your email the whole of the Rainbow Log file. To copy the file, click User Guide and Rainbow Log, then press Ctrl+A to select all and Ctrl+C to copy. You can then paste the copied file into your email by pressing Ctrl+V.

We will aim to (at least) acknowledge your question within one working day, and we will provide a more detailed response as soon as possible depending on the issue. If you need to contact us urgently, you can find our phone number on the Contact page, but we may still need to ask you to provide further details (e.g. screenshots) by email.

Frequently asked questions

Why have the scroll bars at the right and bottom of the screen disappeared?

Rainbow temporarily hides the scroll bars while functions are running in order to speed up processing, and very occasionally (for instance if Excel crashes) the scroll bars may be left in this hidden state. You can restore them in your Excel Options (click File, Options, Advanced), but it’s much quicker just to go to the Rainbow tab, click Summary Report (or any of Rainbow’s main functions), then click Cancel.

Why does the Rainbow add-in download as a zip (compressed) file?

This is a problem with certain older browsers that do not recognise the new Microsoft Office file formats. To resolve the problem, all you need do is change the file extension from “.zip” to “.xlam” (search for “change file extension” if you’re not sure how to do this).

Why does Rainbow Analyst fail to load?

The most likely reason for this is that you need to adjust your macro security settings. The steps to do this in Excel 2007 or 2010 are as follows:

  • Click the File tab (or Microsoft Office Button) and then click Options.
  • Click the Trust Center category.
  • Under Microsoft Office Excel Trust Center, click Trust Center Settings.
  • Click the Add-Ins category.
  • If there is a tick in any of the three checkboxes under this category, deselect the ticked option, and then click OK.
  • Close and re-start Excel, and Rainbow Analyst should load and run as normal.

In earlier versions of Excel, the steps are as follows:

  • Click on Tools, Macro, Security to bring up the Security dialogue box.
  • Select the Trusted Sources tab.
  • Select the check box labelled “Trust all installed add-ins and templates”, and then click OK.
  • Close and re-start Excel, and Rainbow Analyst should load and run as normal.

Why does the Rainbow tab disappear after initial installation?

Following a July 2016 Microsoft Office Security Update, you may need to “unblock” the Rainbow add-in file. To do this, first locate the add-in file RainbowPro.xlam in your add-ins folder as explained on our Installation page.

Then right-click the file in File Explorer (Windows Explorer) and click Properties. At the bottom of the General tab you should see a Security section; check (tick) the box marked Unblock.

Click OK, then close and re-start Excel, and Rainbow Analyst should load and run as normal.

Why does my licence key no longer work?

If your licence key originally worked with Rainbow version 7.2 or earlier, and you haven’t changed your Excel user name, the most likely explanation is that you have downloaded the current version (8.0 or later) of Rainbow Pro. This uses a different system for the licence key (linked to your name and email address), and will not accept your old licence key.

You can upgrade to the current version of Rainbow Pro for a small charge on our Products page, or you can go to the Installation page, scroll down to “Rainbow add-in files”, and re-download the add-in file for Rainbow Analyst Professional 7.2. Just follow the instructions to install this file, and you will be able to re-use your original licence key.

Why do I get asked for the Rainbow Password when I exit from Excel?

This is because certain other software does not properly acknowledge password-protected VBA project files like the Rainbow Analyst add-in file. In particular this problem can be caused by:

  • Google Desktop, or
  • certain COM add-ins for Excel, e.g. WinDIP or the Adobe Acrobat add-in.

The best solution is to find and deactivate the relevant software; you may need to try deactivating or uninstalling several software items until you find which one is causing the problem.

You can view and manage your COM add-ins if you click the File tab and then Options and Add-Ins, then at the bottom of the dialog box select (Manage) COM Add-Ins and click Go. If for instance you then find that the WindDIP add-in is active, you can uncheck the checkbox to deactivate it, or click Remove to uninstall it, then click OK. You may then need to reboot your PC, and you should find that this has resolved the problem.

If for some reason you are unable to identify or deactivate the software that is causing the problem, you could try one or both of the following:

  • In the Rainbow Password dialog box, click Cancel and/or press the Esc key repeatedly until the password box disappears.
  • Press Ctrl+Alt+Del and start Task Manager, then under the Processes tab look for a process named EXCEL.EXE (i.e. an instance of Excel running in the background). Click on this, then click End Process and follow the prompts to close this instance of Excel.

Why can’t I find the folder where the Rainbow log file is stored?

The Rainbow log file (RainbowLog.txt) is stored in a “hidden” folder for temporary files, usually at C:\Users\[Your user name]\AppData\Local\Temp\RainbowAnalyst. Starting with Rainbow Pro version 8.2, the exact location of the file is stated at the beginning (on line 2) of the log file itself.

If you cannot see the AppData folder under your user name folder, this means that you need to enable Windows to show hidden files and folders. In Windows Explorer, click Tools and then Folder Options (in Windows XP or Vista) or click Organize and then Folder and search options (in Windows 7). In the Folder Options dialog box, click the View tab, then under Advanced settings, Hidden files and folders, click “Show hidden files, folders and drives”. Click OK, then close and reopen Windows Explorer, and you will see the AppData folder.

Why does Rainbow change my calculation setting to manual?

Every Excel workbook is saved with a calculation setting; this can be Automatic, Automatic except for data tables, or Manual, and you can find it if you click the File tab (or Microsoft Office button), then Options, then Formulas. Excel can only have one calculation setting (even when more than one workbook is open), so in general it uses the calculation setting of the first workbook that you open. Normally Rainbow Analyst doesn’t affect this setting, even though there is a Rainbow Analyst workbook that forms part of the Rainbow add-in file.

However, versions of Rainbow up to 7.2 sometimes automatically re-save the Rainbow add-in file when you first open it, as a “housekeeping” process to clear out data left over from the previous session. When this happens, Excel applies the calculation setting from the Rainbow add-in file as if it were the first opened workbook, and it ignores the settings in subsequent workbooks. So if for any reason Rainbow was last saved with the calculation set as Manual, then Excel may apply this setting even if you subsequently open a workbook which was saved with the calculation set as Automatic.

This may sound complicated, but the answer is simple:

  • First click the Formulas tab and the Calculation Options button, and select Automatic.
  • If you are using Rainbow 7.2 or earlier, force Rainbow to re-save itself by clicking either Compare Worksheets or Preferences (it doesn’t matter which), then the Save Defaults button.

Why does my Excel screen go blank?

Although Rainbow has been designed to perform quickly and efficiently, in a very large workbook some functions may take many minutes to complete. In this situation the application title (at the very top of the screen) may show “Not Responding”, or the working area of the screen may go blank. This does not indicate a problem; Rainbow is still working away, and you can track its progress on the status bar (near the bottom of the screen). If you do need to interrupt it, just press Esc or Ctrl+Break.

What happens if I change my Excel user name?

If you are using Rainbow version 7.2 or earlier and you change your Excel user name (e.g. after buying a new computer and re-installing Microsoft Office), at first Rainbow will revert to functioning as a 30-day free trial copy. All you need do then is email us at support@themodelanswer.com and let us know your new Excel user name. We will then send you a revised licence key corresponding to your updated user name.

If you are using Rainbow Pro version 8.0 or later, your licence is no longer linked to your Excel user name, and so this problem does not arise.

How do I uninstall Rainbow?

To uninstall Rainbow version 10, simply click Menu Settings on the Rainbow tab, then click Uninstall.

To uninstall earlier versions of Rainbow, you can delete the Rainbow add-in file from your Excel add-ins folder. If you are not sure which is your Excel add-ins folder, see the notes on our Installation page. But you don’t need to delete the file; you can simply deactivate Rainbow in the list of your Excel add-ins (again see our Installation page for more details).

Rainbow Pro versions 8.0 and later make use of the Windows Registry to record certain information. This will not harm your computer, but if you wish to delete this information before uninstalling or deactivating Rainbow, simply click Menu Settings (or in older versions click the down arrow to the right of the Preferences button on the Advanced menu), then click Restore Defaults and click OK.

Back to topAdministration